Excel 2021 : la fonction SOMME.SI.ENS s’enrichit avec les formules matricielles dynamiques

Avec la nouvelle version d’Excel, la fonction SOMME.SI.ENS prend un sérieux coup de jeune. En effet, cette fonction déjà fort pratique bénéficie maintenant des capacités de calcul matriciel dynamique au même titre que les fonctions FILTRE, TRIER ou TRANSPOSE déjà présentées sur ce blog.

SOMME.SI.ENS matricielle dynamique

Les formules matricielles dynamiques permettent à des fonctions d’interagir avec les cellules adjacentes pour y loger le résultat de calculs alors que traditionnellement une formule de calcul ne produit un résultat que dans la cellule où elle est logée. Le nombre de cellules concernées dépend de la taille du résultat ; d’où la notion de formules matricielles dynamiques.

Continue reading ‘Excel 2021 : la fonction SOMME.SI.ENS s’enrichit avec les formules matricielles dynamiques’ »

Mendo, l’assistant personnel Excel

Qui n’a jamais rêvé d’avoir un coach sur Excel ? Eh bien ce que propose de devenir Mendo, votre entraîneur personnel.

MENDO

Mendo se présente comme un add-on Excel à télécharger. Il rajoute un menu dans Excel.

Dès que vous travaillez sur une feuille de travail, il vous propose de vous aidez à améliorer vos tableaux de données.

Continue reading ‘Mendo, l’assistant personnel Excel’ »

Analyse de données et automatisation avec Excel et Access (4ème volet)

La partie de la formation consacrée à Excel touche à sa fin cette semaine. Après un premier volet portant introduction du sujet de l’analyse de données, un deuxième et un troisième volet abordant les fonctions fonctions de calcul d’Excel ainsi que la mise en forme des données. Ce quatrième volet se consacre essentiellement au tableau croisé dynamique (TCD).

Volet 4 - TCD

Au programme cette semaine :

Continue reading ‘Analyse de données et automatisation avec Excel et Access (4ème volet)’ »

Excel : nommer des cellules

Pour faciliter la lecture des formules de calcul, il est possible de nommer des cellules ou des plages de cellules et de faire référence à ces noms en lieu et place de ces cellules/plages dans les formules.

XL NOMS1

Exemples de calcul avec des noms :

  • Plage nommée : =SOMME(HT) au lieu de =SOMME(A5:A20)
  • Cellule nommée : =HT*Tx_TVA au lieu de =C5*D5

Continue reading ‘Excel : nommer des cellules’ »

Excel : fiabiliser la saisie de données avec la validation de données

La validation de données fiabilise la saisie des données en les soumettant à des critères prédéfinis. Les saisies qui ne correspondent pas aux critères sont empêchées.

VALIDATION DONNEES Options

A titre d’illustration, cet article s’appuiera sur exemple. L’utilisateur sera invité à saisir un montant et Excel listera tous les comptes de la balance pour lesquels le solde comptable est supérieur.

VALIDATION DONNEES BalanceContinue reading ‘Excel : fiabiliser la saisie de données avec la validation de données’ »